Problemă de wordpress

WORDPRESS-SUX

Am o problemă la wordpress căreia nimeni nu îi poate da de cap.
Wordpress nu mai crează thumbnails din imaginea uploadată, prin urmare, pe prima pagină, îmi arată poza originală, redimensionată. Dacă am 20 de poze de 1MB, GÂNDIȚI-VĂ la cât ajunge homepage-ul meu. Tot cu ocazia asta am observat și că Cleaner Gallery a decis să crape și să nu mai redimensioneze pozele frumos în galerii, prin urmare arată ca aruncate din pod.

Ceva idei de alea care să conteze, nu Ai încercat să dai disable la pluginuri și revert la o temă standard?

Ah, câteodată așa mă mănâncă să pun un CMS dedicat...

Solved. voia restart hhvm

__________________________________________________________
Dacă ți-a plăcut articolul, dă-mi o bere virtuală BERE 9 beri
Loading...

35 comentarii

  1. #1

    joomla ? :)))

    Thumb up 0 Thumb down 0

  2. #5

    E de cand ai modificat tema, sau a aparut din senin? Un plugin de rebuild thumbnails ai incercat?

    Thumb up 0 Thumb down 0

  3. #6

    Ai încercat să dai disable la pluginuri și revert la o temă standard?

    Thumb up 0 Thumb down 0

  4. Nu cumva ai dezactivat thumbnail generation din Settings>Media? Daca ai spatiile goale la
    Thumbnail size(150x150px ) atunci sistemul nu va genera thumbnail la upload. Asta e singura cauza, daca totusi ai activata optiunea, poate e salvat diferit in baza de date.

    Thumb up 0 Thumb down 0

    • Mai poate fi de la versiunea PHP sau daca ai activat sau nu php gd2. Worth a try... Ai schimbat ceva setari la VPS?

      Thumb up 0 Thumb down 0

  5. nasol sa nu ai pe nimeni in agenda 🙂

    Thumb up 0 Thumb down 0

  6. #11

    Iti fac o oferta de pret frumoasa pentru un CMS custom 😀

    Thumb up 0 Thumb down 0

    • #12

      ca dupa aia, la fiecare functionalitate de care am nevoie, sa iti plang la usa:))) no tks, cam de aia refuz constant de 5 ani ideea unui cms

    • #13

      Faci o lista de 10-15 chestii care crezi ca ti-ar folosii, se implementeaza, si dupa, oricum te ajut fara costuri 😛

      Thumb up 0 Thumb down 0

    • #14

      iti da garantie boss.

      Thumb up 0 Thumb down 0

    • #15

      daca scrie "folosi" cu doi de i si pune si virgula inainte de "si" e foarte bun, eu zic sa nu-l scapi

      Thumb up 0 Thumb down 0

    • #16

      Sa compari un programator dupa greselile gramaticale este o greseala.

      Thumb up 0 Thumb down 0

    • #17

      Mai zi-ne, Danielo, cum e cu virgula aia interzisa inainte de "si"!

      Thumb up 0 Thumb down 0

    • #18

      @paul
      sa-l compari cu cine? cu un tamplar? cu un politician? cu o barza medaliata cu bronz?

      Thumb up 0 Thumb down 0

  7. #19

    Verifica permisiunile directorului wp-content/uploads. Ar trebui sa fie read/write = owner, read/write = group, read = others
    In general se repara cu comenzile de mai jos executate cu drepturi de root (sau cu sudo in Ubuntu):
    "chmod -R 644 wp-content/uploads" sau "chmod -R 775 wp-content/uploads" ... depinde cum ai configurat serverul.

    Daca a fost facut un update/upgrade la php, verifica daca mai ai extensia php_gd activa. (creaza un fisier php, pune acolo "<?php phpinfo();" fara ghilimele si vezi daca apare GD in lista de extensii). Daca nu apare, trebuie instalata.

    Thumb up 0 Thumb down 0

  8. #20

    Cunosc eu un mester bun in Brasov care se ocupa de bricolaj&stuff care cred ca te-ar putea ajuta.

    Thumb up 0 Thumb down 0

  9. #21

    La țanc: Cine se pricepe să modificie o temă WordPress (cumpărată de la Templatic) ca să afișeze galeria de imagini din header în textul postării. Pentru cei interesați de mai multe detalii pot trimite un mail la numele din comentariu @yahoo.com Mulțumesc Arhi pentru această postare, sper să îi dau și eu de cap.

    Thumb up 0 Thumb down 0

  10. #22

    Reverse engineering la plugin/tema. Sigur trebuia/trebuie să facă thumbnails separat?

    Thumb up 0 Thumb down 0

  11. #23

    Si eu am patit la fel dupa upgrade.
    Ca sa nu ma chinui am făcut downgrade la versiune in așteptarea uneia care nu face figuri.

    Thumb up 0 Thumb down 0

  12. #24

    Incearca cu plugin-ul Regenerate Thumbnails, posibil sa rezolve problema.

    Thumb up 0 Thumb down 0

    • #25

      Da, întotdeauna aruncatul cu ȘI MAI MULTE PLUGIN-URI în problemă a fost soluția =)))

      Thumb up 0 Thumb down 0

  13. lol. had that last week.

    Thumb up 0 Thumb down 0

  14. #28

    Aaam. Nea' automatic nu a facut pe repo la wordpress nici o modificare la the_post_thumbnail().

    Din cate vad, ultimul thumbnail e facut prin 11.04 pana acum ... damn

    Nu stiu ce servicii ofera chroot, gen daca poti sa dai un restart la VPS, sau ai doar cPanel/WHM sau doar ssh acces.

    Problema 0. Desi din aprilie pana in prezent e mult poti sa dai restart la VPS - yep mwie cPanel.
    Problema 1. permisii foldere
    Problema 2. functions.php - din tema nu wordpress - vezi daca e ceva diferit de bkp gen martie.
    Problema 3. Cleaner Gallery e discontinued de 2 ani ... wtf

    Thumb up 0 Thumb down 0

    • #29

      daca alta nu e....

    • #30

      e server, nu e vps. am acces la orice

    • #31

      aia a fost, restart de hhvm. now works

    • #32

      Super ! Restart-ul sitemelor mie mi-a rezolvat foarte foarte multe probleme.

      Thumb up 0 Thumb down 0

  15. Eu am crezut ca nu am setat drepturile bine pe masina Amazon unde am urcat blogul. E oarecum o consolare sa vad ca e "de la ei", ca poate repara la upgrade-ul urmator. 😉

    Thumb up 0 Thumb down 0

    • @Cetin: Cred ca trebuie sa iti dau o bere. La mine problema cu extensia GD era.

      Thumb up 0 Thumb down 0

    • #35

      demult trebuie sa ne dam noi bere :))